Bフレッツの接続でブロードバンドルータを1812jで設定

公開日:

昨日は無事にBフレッツの工事が終わりました。
ヘルプの人入れて3人もの人がいろいろやってくれて3時間ちょっとで開通しました。
でもって、家にあるciscoの1812jでとりあえずは繋ぐことにしました。

回線:NTTのBフレッツベーシック(100M固定のです)
プロバイダ:i-revo 固定IP1つ付いて500円!!
ルータ:シスコの1812j iosは12.4です。

■設定

interface Loopback0
ip address 12X.XX.XX.XX 255.255.255.255

interface FastEthernet0
no shutdown
pppoe enable
pppoe-client dial-pool-number 1

interface Vlan1
ip address 192.168.0.XX 255.255.255.0
ip nat inside
ip tcp adjust-mss 1414
!
interface Dialer1
ip unnumbered Loopback0
ip mtu 1454
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname XXX123456@i-revonet.jp
ppp chap password XXXXXXXX
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
ip nat inside source static tcp 192.168.0.X 80 interface Loopback0 80
ip nat inside source static tcp 192.168.0.X 443 interface Loopback0 443
!
dialer-list 1 protocol ip permit
!

■説明


interface Loopback0
ip address 12X.XX.XX.XX 255.255.255.255

L0にプロバイダーからもらった固定IPアドレスを入力。


interface FastEthernet0
pppoe enable
pppoe-client dial-pool-number 1
no shutdown

ONUに接続するポートです。上から順番に説明
PPPoEを有効
論理インターフェースDialer1を使ってPPPoEセッションを確立


interface Vlan1
ip address 192.168.0.XX 255.255.255.0
ip nat inside
ip tcp adjust-mss 1414

サーバ側のVlan設定
アドレス
natの内側
TCPセッションの最大セグメントサイズ


interface Dialer1
ip unnumbered Loopback0
ip mtu 1454
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname XXX123456@i-revonet.jp
ppp chap password XXXXXXXX

PPPoEを設定する仮想IFの設定
アドレスはunnumberedでL0を参照させる
パケットの最大サイズをNTT指定の1454へ
natのoutside
PPPでカプセル化
dialer pool 1でこの論理IFを実際にPPPoE接続する物理IFに紐付け
dialer-group 1でdialer-listコマンドで定義するトラフィックパターンをIFに適用
ISPにアクセスする際の認証方法を設定
ISPから払い出されたユーザー名を設定
ISPから払い出されたCHAP認証のパスワードを設定 ※このパスはi-revonetの場合、Web上から申し込みを実施したときにWeb上に表示されるパスワードです。その後、メールが届きますがユーザー名だけでこのパスの記載わないので表示されたのをちゃんとコピーしておいたほうがいいです。メールが届いたんで消しちゃうところでしたよ。


ip route 0.0.0.0 0.0.0.0 Dialer1

デフォゲをDialer1へ


ip nat inside source static tcp 192.168.0.1 80 interface Loopback0 80
ip nat inside source static tcp 192.168.0.1 443 interface Loopback0 443

natをスタティックで設定


dialer-list 1 protocol ip permit

PPPoE接続を開始するトラフィックをダイヤラーリストに設定

■確認

セッションが張れるとこうなります。
#show pppoe session
1 client session

Uniq ID PPPoE RemMAC Port VT VA State
SID LocMAC VA-st
N/A 31101 0015.c773.281a Fa0 Di1 Vi2 UP
001b.0c90.313e UP

■感想
PPPoEの設定なんて簡単だろうと勝手に思ってたんですが、そういえば固定IP1つの場合ってどう設定したらいいんだろうとか?あれ?簡単じゃねえぞ。なんてことになりました。
ダイワボウさんの本があったんで何とかなりました。参照した本を下に貼っておきます。31ページです。

■その他、vlanの設定
最初、IOSのバージョンが12.3ので設定してて、vlan切ろうとしたら切れなくて何時間か格闘してました。
vlanの設定がvlan databaseだし(applyなんて知らんわ)、vtpがclientモードで他のに変えれなくってvlanが設定できん。
しかしIOSが12.4ので試したらすんなり切れました。vlan databaseも使わないでいいし簡単に出来ました。お気をつけください。


作成者: ひろしっち

プロのマジシャンやってます。 こちらは昔のブログから移行した記事とマジックとは関係ない記事などです。 マジック関連は以下をご覧ください。 ひろしつちや マジシャン出張、派遣マジックショー 記事の感想、コメント、質問などはTwitterにお願いします。 フォローも良かったらお願いします。 Instagram / YouTube / Facebook